Предупреждения open-vm-tools

При установке пакета open-vm-tools вы можете увидеть следующие предупреждения: CONFIG_VMWARE_BALLOON: is not set when it should be CONFIG_VMWARE_VMCI: is not set when it should be CONFIG_VMWARE_VMCI_VSOCKETS: is not set when it should be Чтобы избежать их появления в дальнейшем, нужно внести ряд изменений в ядро и пересобрать его. Для этого запускаем genkernel —menuconfig all Находим нужные опции в конфигураторе Device Drivers => Misc Devices => <*> VMWare VMCI Driver Device … → …

Настройка OpenVPN. Одновременная работа по udp, tcp протоколам

Стандартная настройка OpenVPN — работа по протоколу udp. Однако бывают случаи, когда нужно перейти на tcp. Например, решением следующей ошибки TLS Error: TLS key negotiation failed to occur within 60 seconds стал переход на использование протокола tcp для одного-двух клиентов А что делать с остальными клиентами? Подключаться к каждому по teamviewer’у для редактирования конфига не вариант. Тогда нужно настроить OpenVPN на работу по двум протоколам. Но стандартная его настройка не … → …

Несколько php версий на одном сервере. Gentoo Linux

В gentoo linux есть возможность установки несколько php версий на один сервер. Рассмотрим подробнее как это сделать на примере сервера с ОС gentoo x64. На момент написания статьи в портажах есть несколько версий php-5.6.29 php-5.6.30 php-7.0.15 php-7.1.1 Мы будем устанавливать php-5.6.30 и php-7.1.1. Для начала добавляем в make.conf строки PHP_TARGETS=»php5-6 php7-1 php7-2 php7-3″ PHP_INI_VERSION=»production» php7-2 php7-3 — это задел на будущее. Когда эти версии окажутся в портажах не нужно будет … → …

Установка Gentoo. Коротко и ясно

В статье рассматривается установка gentoo — одного из дистрибутивов Linux. Статья не обьясняет многие технические термины и не является заменой официального handbook. Установка проводится на виртуальный сервер под управлением vmware esxi6.5. Предполагается, что виртуальный сервер уже создан средствами ESXi Embedded Host Client и имеет следующую конфигурацию: CPU: 2*2.0Hhz Xeon RAM: 2Gb HDD: 40GB Net: 2 сетевые карты в разных виртуальных свичах CDROM: в качестве диска имидж gentoo-install-amd64-minimal-20150521.iso взятый с сайта … → …

Установка mariadb client на gentoo

Проблема Не получается выполнить установку mariadb client на gentoo. Возникает ошибка конфликта взаимной блокировки [blocks B ] dev-db/mariadb («dev-db/mariadb» is blocking dev-db/mysql-5.6.24) [blocks B ] dev-db/mysql («dev-db/mysql» is blocking dev-db/mariadb-10.0.19) Решение Для полноценной установки только клиента mariadb нужно использовать следующие флаги dev-db/mariadb minimal -perl virtual/mysql minimal Александр Черных системный администратор 0